Search

Archives

Pages

Op mijn desktop:

Suggesties, commentaar, ... (klik of schrijf zelf:)e-mail webgang

Private

Laatste titels:

Bug/FR (Covid19DataBE): gb.chart not found

WebGang blog ** September 1st, 2020 by wim.webgang **

Gambas en OpenSUSE
Bij Gambas 3.10, die standaard bij bv opensuse Leap 15.1 zit, is de chart module (die gebruikt wordt om de grafiek te tekenen) niet beschikbaar. Daardoor krijg je volgende foutmelding:

Some components are missing: gb.chart

Wat je kan doen is een nieuwere versie van Gambas 3 installeren. Er zijn andere repositories (softwareverzamelingen) te vinden waarin bv gambas versie 3.14 of 3.15 zit.
https://software.opensuse.org/package/gambas3-ide is de hele omgeving (gemakkelijkst om het programma te “maken” – te compileren op je computer).
Je ziet onder de link een andere optie:

Show Gambas3-ide for other distributions

Zo heeft OpenSUSE Leap 15.2 of tumbleweed Gambas 3.14.3, maar Leap 15.1 slechts 3.10.

Klik daarom op “show experimental packages” of op “show community packages”. Dan heb je meer keuze:

Education Experimental
3.14.3
home:munix9 Community
3.15.1

Klik op “1 click install”, en Yast opent om te installeren.

Misschien moet je even in de software-installatie tool van Yast gaan en de andere onderdelen van Gambas3 ook installeren als je merkt dat gambas3 niet start; meestal omdat er een stukje ontbreekt.

Dat kan je zien als je op de commandolijn “gambas3″ start.
bv:
gambas3
gbx3: unable to find startup file

Software installeren (zoek: gambas3).
Scroll naar beneden bij alle onderdelen van gambas3, en kijk of er (behalve de debug paketten) belangrijke paketten niet zijn geselecteerd. Installeer bij en probeer opnieuw.
Een voorbeeld van zo’n pakket is:

gambas3-gb-jit – The Gambas JIT component
This component provides the JIT compiler for Gambas.

Lift ^ | Lift v | Comments Off

Comments are closed.